Présentation de l'algorithme :

Algorithme qui détermine si un quadrilatère caractérisé par les coordonnées de ses quatres sommets est un parallélogramme.

Tester l'algorithme :


(cliquer sur le bouton ci-dessus pour lancer ou relancer l'exécution de l'algorithme)
Remarque : si les messages "Algorithme lancé" et "Algorithme terminé" n'apparaissent pas au bout d'un moment dans la zone ci-dessous, c'est que l'algorithme contient une erreur.

Résultats :

Code de l'algorithme :
1     VARIABLES
2       x_A EST_DU_TYPE NOMBRE
3       y_A EST_DU_TYPE NOMBRE
4       x_B EST_DU_TYPE NOMBRE
5       y_B EST_DU_TYPE NOMBRE
6       x_C EST_DU_TYPE NOMBRE
7       y_C EST_DU_TYPE NOMBRE
8       x_D EST_DU_TYPE NOMBRE
9       y_D EST_DU_TYPE NOMBRE
10      x_AB EST_DU_TYPE NOMBRE
11      y_AB EST_DU_TYPE NOMBRE
12      x_DC EST_DU_TYPE NOMBRE
13      y_DC EST_DU_TYPE NOMBRE
14    DEBUT_ALGORITHME
15      LIRE x_A
16      LIRE y_A
17      LIRE x_B
18      LIRE y_B
19      LIRE x_C
20      LIRE y_C
21      LIRE x_D
22      LIRE y_D
23      x_AB PREND_LA_VALEUR x_B-x_A
24      y_AB PREND_LA_VALEUR y_B-y_A
25      x_DC PREND_LA_VALEUR x_C-x_D
26      y_DC PREND_LA_VALEUR y_C-y_D
27      SI (x_AB==x_DC et y_AB==y_DC) ALORS
28        DEBUT_SI
29        AFFICHER "ABCD est un parallélogramme"
30        FIN_SI
31        SINON
32          DEBUT_SINON
33          AFFICHER "ABCD n'est pas un parallélogramme"
34          FIN_SINON
35      TRACER_POINT (x_A,y_A)
36      TRACER_POINT (x_B,y_B)
37      TRACER_POINT (x_C,y_C)
38      TRACER_POINT (x_D,y_D)
39      TRACER_SEGMENT (x_A,y_A)->(x_B,y_B)
40      TRACER_SEGMENT (x_B,y_B)->(x_C,y_C)
41      TRACER_SEGMENT (x_C,y_C)->(x_D,y_D)
42      TRACER_SEGMENT (x_D,y_D)->(x_A,y_A)
43    FIN_ALGORITHME